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Getting Started

Introduction - The Kubotek KeyCreator Advantage
 
Welcome to KeyCreator’s Test Drive Guide.  This guide is intended to introduce you to the exciting and productive world of design freedom and 
creativity using KeyCreator’s ground-breaking history-free modeling tools.

We hope you find this guide, both informative and useful while starting to use KeyCreator’s unique productivity tools!

In this guide you will learn why KeyCreator is the ultimate choice for manufacturing your engineering and design needs.  With history free design 
creativity - the road is open, not mandated…

In this test drive you will learn how KeyCreator offers:
 Modeling tools specifically designed with the design & manufacturing engineer in mind – not just software gurus. 
 Simple, history-free methods – to create designs using a more natural and effective workflow.
 

Furthermore, you will see how parametric, history based tools have become an ingrained behavior – not only are they unnecessary for most 
occasions, you will soon realize how much of a burden they can be.  KeyCreator offers the easiest-to-use transition from 2D-to-3D; and you can 
become productive very quickly with this new design modeling approach!

The KeyCreator approach will help you become more effective at what you do best – design and manufacture products.

*Please Note: This Test Drive is not a replacement for training. To take full advantage of KeyCreator’s many powerful capabilities, we highly 
recommend you attend standard training offered by Kubotek3D.  

There are many options for training, including custom on-site, internet-based, or traditional classroom classes at Kubotek3D headquarters in 
Marlborough, MA.
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Part Design

We shall look at some of the easy, powerful and unique aspects of designing parts in KeyCreator:

Using ‘building block’ methods [simple primitives vs. constrained sketches] to create 3D designs
Designing without complex part/history structures
Generic modification

We will be creating a handlebar Triple Clamp seen in the picture below.
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Using ‘building block’ methods [simple primitives vs. constrained sketches] to create 3D designs
Designing without complex part/history structures
Generic modification

We will be creating a handlebar Triple Clamp seen in the picture below.

Keep in mind as you proceed that you can utilize the Drawing/Detailing and 
Solid/Surface Palettes to create and modify geometry.

Let’s begin!Let’s begin!

Basic primitive solid creation:

This guide is setup to create the model in INCH units. Let’s start with a 
new file and the American template file for inches. 

From the File dropdown menu select New by Template. Choose Template.

Select the American.CKT file from the dialog window.

Let’s start by building the base mounting block.
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1. Select Create>Primitive Solid>Cylinder.

Hint: You can Auto-scale, Zoom, Pan or Rotate your model at any time using these icons on your screen.

2. A dialog window will open. Select the options below.

3. Select a center point for the cylinder on the screen. The location can be anywhere on 
the screen. Once you have the center point you can drag your mouse and the base of 
the cylinder will start to appear. Pick a point on the screen for the radius to lock in. Don’t 
worry about the sizes right now.

6. Now let’s enter the values for the radius and height. Select the Red 
arrow. You can now enter the value for the radius. For this example 
enter the value of 2 then hit Enter on your keyboard.
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4. Once the radius point has been selected you will be able to move 
the mouse in the Z direction. Move the mouse and select a point for 
the height. Again don’t worry about the size, we will enter values next.

5. At this point you should see small red and blue arrows at the top 
of the cylinder. If you drag the red arrow you dynamically change the 
radius. If you drag the blue arrow you dynamically change the height.

6. Now let’s enter the values for the radius and height. Select the Red 
arrow. You can now enter the value for the radius. For this example 
enter the value of 2 then hit Enter on your keyboard.

7. Now select the Blue arrow and enter the value of 3 for the height.
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8. Now that you have entered the radius and height values select 
Accept in the Conversation Bar. This will create the cylinder. Do not 
escape out of the function.

9. Since you are still in the function create another cylinder with the 
radius of 1.5 and the  height of 2.125  Select Escape when done.

Don’t worry about the location just make it similar to the image below.

Do not escape out of the function.

10. Lets use Dimension Driven Editing to position the cylinders.
             Modify>Dimension Driven Edit

11. Select the larger cylinder as shown below. Just mouse over the 
edge and select it.
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11. Select the larger cylinder as shown below. Just mouse over the 
edge and select it.

12. A dimension will appear on the screen. Do not place that 
dimension just yet. Mouse over to the other cylinder.

13. When you mouse over the smaller cylinder the edge will highlight. 
Select it.

14. Now that you selected the second cylinder you get a dimension 
between the 2. Place it using the left mouse button as shown below.

15. Now select the same 2 cylinders but do not place the dimension.
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16. Press the Right Mouse Button and a menu will come up with 
options. Select the Vertical option. This will change the dimension from 
Horizontal to vertical.

17. Place the dimension as shown below. Do not escape out of the 
function.

NOTE: To learn more about Direct Dimension Editing watch the videos below.

18. Select the right side of horizontal dimension shown. The side face 
of the small cylinder should highlight.

20. Select the bottom side of vertical dimension shown. The side face 
of the small cylinder should hightlight.

https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1201/KCV1201.mp4

https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1202/KCV1202.mp4

https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1203/KCV1203.mp4

https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1201/KCV1201.mp4
https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1202/KCV1202.mp4
https://kubostatic.kubotek3d.com/sup/kcuassets/videos/KCV1203/KCV1203.mp4
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17. Place the dimension as shown below. Do not escape out of the 
function.

18. Select the right side of horizontal dimension shown. The side face 
of the small cylinder should highlight.

19. In the conversion bar enter the value of 8.5 Then OK.

20. Select the bottom side of vertical dimension shown. The side face 
of the small cylinder should hightlight.

21. In the conversion bar enter the value of 1.0 Then OK.

This will change the dimension and distance between the 2 solids to 
8.5

This will change the dimension and distance between the 2 solids to 1
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22. Select Create>Primitive Solid>Block. A dialog window will open. 
Use the settings below.

23. For the first point of the block select center of the large cylinder. To 
get the center all you need to do is mouse over the bottom edge and it 
will snap to the center point.

24. Now drag the block shape until you snap to the point (quad) of the 
smaller cylinder shown below.

25. Once you select the second point you can now move in the Z 
direction for the height. To enter the height select the small Blue arrow 
and enter the value of 1.5

* Do Not select OK after you 
enter the height. You will be 
adjusting the location of the 
block before you finish the 
function.

25. To adjust the location before you create the block you can select 
the Green arrow and drag to a new location. In this example enter the 
value of .95

27. The model should look like the one below at this point.
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23. For the first point of the block select center of the large cylinder. To 
get the center all you need to do is mouse over the bottom edge and it 
will snap to the center point.

25. Once you select the second point you can now move in the Z 
direction for the height. To enter the height select the small Blue arrow 
and enter the value of 1.5

25. To adjust the location before you create the block you can select 
the Green arrow and drag to a new location. In this example enter the 
value of .95

26. Then select the Blue curved arrow and enter an angle of -5 
degrees. Now you can select OK to create the block.

27. The model should look like the one below at this point. 28. Now let’s refine the shape of the block. Select Modify>Dynamic 
Face.
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29. Select the face shown below and the OK in the Conversation Bar. 30. Now a DynaHandle will appear at the center of the face. This 
means that if you modify the face the modification will be based off 
this location.

31. You can move the location of the DynaHandle to a new location. 
Mouse over the Yellow ball of the DynaHandle, it will turn Orange. 
Using the Left Mouse Button drag the ball over the edge of the large 
cylinder and it will snap to the center.

NOTE: When using the DynaHandle you can use the Right Mouse 
Button over the different arrows for extra menus. Before moving 
the DynaHandle select the ball with the RMB and make sure the 
Xform option is not checked. If it is it will move the face instead of 
the DynaHandle.
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30. Now a DynaHandle will appear at the center of the face. This 
means that if you modify the face the modification will be based off 
this location.

31. You can move the location of the DynaHandle to a new location. 
Mouse over the Yellow ball of the DynaHandle, it will turn Orange. 
Using the Left Mouse Button drag the ball over the edge of the large 
cylinder and it will snap to the center.

32. Select the Blue Arrow and enter a value of .5 to raise the height of 
the face.

33. Select the Green curved arrow and enter a value of 5 degrees. 
Then Select OK. Do not escape the function.

34. Select the face shown below and select OK. 35. Next let’s select the face on the other side but that face needs to 
change in the opposite direction. To do this select Add Inv button on 
the Conversation Bar.
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36. Rotate the model and select the face on the other side as shown 
below. Then select OK.

37. Move the center (Yellow ball) of the DynaHandle to the center of 
the top of the large cylinder just like you did in step 31.

38. Select the Red curved arrow and enter 2 degrees for the angle. As 
you can see this rotates both faces in a opposite direction from each 
other. Select OK when done.

39. Select Modify>Boolean>Unite
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37. Move the center (Yellow ball) of the DynaHandle to the center of 
the top of the large cylinder just like you did in step 31.

39. Select Modify>Boolean>Unite

40. Select the 2 solids shown below to join together into one. Select 
OK when done.

41. Select Create>Solid Feature>Blend>Constant Blend

42. Enter a radius of .25 in the small dialog window that opens. 43. Select the 2 edges shown below and then OK.
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44. Once the blends have been created select the edge shown below 
then select Accept. This will create a blend along the entire edge, not 
just the one selected.

45. Select Escape to exit the blend function. The blends should look 
like the ones below.

47. Mouse over the blend edge as shown. Select the blend edge and 
place the dimension. Do not exit the function.

46. Lets use Dimension Driven Editing to change the size of the blends.
             Modify>Dimension Driven Edit

When you mouse over the 
blend edge the Tooltip will 
give you information about 
the blend.
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45. Select Escape to exit the blend function. The blends should look 
like the ones below.

47. Mouse over the blend edge as shown. Select the blend edge and 
place the dimension. Do not exit the function.

48. Now if you mouse over the same dimension all of the blends will 
highlight. That’s because they are all the same radius.

49. Just because all the blends highlight doesn’t mean they all need 
to change. You have the ability to Add and Remove blends from the 
selection.

In the Conversation Bar select the Remove button.

50. Select the 2 long blends and then Accept. 51. These blends are now removed from the selection.
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52. In the Conversation Bar change the radius value to .35 and then 
select OK.

53. Select Create>Solid Feature>Hole

54. Select Through hole with a diameter of 2 55. Select the face shown below for the hole.

This will change only the highlighted blends.
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53. Select Create>Solid Feature>Hole

55. Select the face shown below for the hole.

56. Mouse over the outside edge as shown and it will automatically 
snap to the center.

57. The hole should look like the one below when done.

58. Rotate the model to the other side to shell it out. 59. Select Create>Solid Feature>Shell
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60. Set options as below. Shell value should be .125 then select OK. 61. Select the face shown below and the OK.

62. After the shelling operation the model should look like the one 
below.

63. Now the area with the through hole needs more material. Let’s use 
Dynamic Face to add more material.
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61. Select the face shown below and the OK.

63. Now the area with the through hole needs more material. Let’s use 
Dynamic Face to add more material.

64. Select Modify>Dynamic Face. 65. Select the face shown below and OK.

66. RMB on the arrow shown below and make sure Offset is selected. 67. You can drag the arrow to offset the thickness, select the arrow 
and enter the value of .35 then select OK.
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68. Once material has been added you don’t need the Blend anymore. 
Let’s remove it by selecting Modify>Solid Face>Remove.

69. In the Conversation Bar select Feature, then Blend, then Constant

70. Mouse over the blend shown below. It will automatically highlight 
when you mouse over. Select it the blend.

71. Select OK to remove it.

72. In an earlier step you modified a blend using a dimension. Let’s try 
another way using Dynamic Face.

Select Modify>Dynamic Face.
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69. In the Conversation Bar select Feature, then Blend, then Constant

71. Select OK to remove it.

73. Select the blends shown below and then OK.

74. An arrow appears, drag this to change the radius size. You can 
type in a value by selecting the arrow. For this example just drag the 
arrow and select OK.

75. Now let’s try another way to modify a blend. 

Select Modify>Solid Feature>Blend

72. In an earlier step you modified a blend using a dimension. Let’s try 
another way using Dynamic Face.

Select Modify>Dynamic Face.
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76. Select the same 2 blends as before and then OK. 77. Enter a value of .5 in the Conversation Bar, then OK.

78. Let’s change the creation color. Select the color icon
at the top of the interface.

Select a new creation color. For this example I’ll use number 27 Red 
from the color palette that comes up.

79. Now let’s add a rib for strength. You could create it using the 
primitive solid function, but in this example we are going to create it 
from existing geometry.

Select Modify>Topology>Unstitch

This will change the blend radii to .5   



27

77. Enter a value of .5 in the Conversation Bar, then OK.

79. Now let’s add a rib for strength. You could create it using the 
primitive solid function, but in this example we are going to create it 
from existing geometry.

Select Modify>Topology>Unstitch

This will change the blend radii to .5   

80. Make sure the options in the dialog window that opens are set like 
the ones below. Then select OK.

81. Select the face shown below and OK. This will create a copy of the 
face.

82. Let’s hide the solids and keep just the new face created.
Select the Hide icon at the top of the interface.

83. Now you can take the flat face and turn it into a 3D solid.
Select Modify>Dynamic Face

After selecting the icon select OK to hide what you are about to select 
next.

Select the 2 solids and then OK. This will keep only the new face 
visible.
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84. Select the face and then OK. 85. Mouse over the Blue arrow with the RMB and change the option to 
Extrude.

86. Once you’ve changed the option to Extrude you can mouse over 
the Blue arrow with the RMB and change the option to Extrude angle 
to 4 degrees.

87. Now as you start to drag the blue arrow you will see the face turn 
into a 3D solid with 4 degrees of draft.

Just mouse over and select the Draft Angle and in the Conversation 
Bar enter a value of 4 then OK to change the angle.
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85. Mouse over the Blue arrow with the RMB and change the option to 
Extrude.

87. Now as you start to drag the blue arrow you will see the face turn 
into a 3D solid with 4 degrees of draft.

88. Select the blue arrow and enter a value of .75 then OK. 89. Stay in the same function. Select the face shown below and then 
OK.

90. Select the Blue arrow and enter the value of .3 then OK. 91. Now let’s change the thickness of the rib. Staying in the same 
function select the face shown below, then select the one on the other 
side shown in the next step.



30

92. Select face shown below then OK. 93. Select the Blue arrow with the RMB and select Offset.

94. Once you set the option to Offset select the arrow and enter the 
value of -.3 then OK.

95. The rib should now look like the one below.
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93. Select the Blue arrow with the RMB and select Offset.

95. The rib should now look like the one below.

96. Let’s unhide the solids.

Select the Unhide icon at the top of the interface.

97. Now let’s union the rib into the solid.

Select Modify>Boolean>Unite

98. Select the 2 solids shown below to join together into one. Select 
OK when done.

99. The model should look like the one below at this point.

Select the 2 hidden solids and then OK.
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100. You’ve only created one side of the triple clamp so far. So let’s 
mirror the one created to get the other side.

You can switch to the top view using the Top View icon located on the 
right side of the interface.

Then select Transform>Dynamic Copy

101. Select the solid shown below and OK.

102. Mouse over the cylinder shown until the center snap comes up. When the center snap comes up select it to place the DynaHandle.
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101. Select the solid shown below and OK. 103. Select the Blue arrow with the RMB and select Mirror. This will 
mirror the copied solid based on that vector/arrow.

104. Select OK. If you forget to select OK the solid will not mirror but 
you will still have the copy on top of itself.

105. The model will look like the one below after the mirror. 106. Now let’s union the 3 solids together.

Select Modify>Boolean>Unite
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107. Select the 3 solids, then OK. 108. Let’s add a hole in the middle cylinder. But this time let’s use the 
hole feature function.

Select Tools>Feature>Counterbored Hole

109. A dialog window will open with the hole information. Since you 
are doing this in inches make sure the hole information is set to inches 
by selecting the Setup tab and setting it to English.

110. Now back on the Cbore tab use the options below and select OK.
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108. Let’s add a hole in the middle cylinder. But this time let’s use the 
hole feature function.

Select Tools>Feature>Counterbored Hole

110. Now back on the Cbore tab use the options below and select OK.

111. Select the solid. 112. You should now see the hole shape in wireframe moving with 
your mouse.

113. Mouse over until you snap to the top of the large cylinder and 
select it. This will automatically cut the hole out in the solid.

114. The model should look like the one below now.
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115. Now that you know how to add some holes let’s use the modify 
hole function to change some.

Select Modify>Solid Feature>Hole.

116. You are going to modify the 2 outside holes. If you mouse over 
one of the holes it will highlight and the tooltip will display the hole 
information. If you select the Pattern button (see next step) 2 holes 
will highlight since they are a pattern.

117. To modify both holes at the same time select the Pattern button 
in the Conversation Bar. Then all you need to do is mouse over one 
hole and any pattern will highlight.

118. Select OK twice. A dialog window will open. Set the options like 
below. Then select OK.

NOTE: If you use the Pattern option all patterns will highlight 
of the selected hole. Even if they are on another solid.
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116. You are going to modify the 2 outside holes. If you mouse over 
one of the holes it will highlight and the tooltip will display the hole 
information. If you select the Pattern button (see next step) 2 holes 
will highlight since they are a pattern.

118. Select OK twice. A dialog window will open. Set the options like 
below. Then select OK.

119. Select the 2 faces shown below. This is to define the top face of 
the hole(s). Then OK.

120. Now the holes have changed. 

121. Let’s add some blends to where the side ‘wings’ mate to the 
center cylinder.

Select Create>Solid Feature>Blend>Constant Blend

122. Enter the value of .4 in the dialog window and select OK.
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123. Select the edges shown below and then OK. 124. The blend will be automatically adding along the edges.

125. Finally let’s change the angle between the side ‘wings’. 126. Select Modify>Dynamic Face.
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124. The blend will be automatically adding along the edges.

126. Select Modify>Dynamic Face.

127. Window in the right side as shown below. To window hold down 
the LMB and drag across the part until the faces you want are inside 
the window.

128. Select OK when done windowing in the faces.

129. The other side needs to change in the opposite direction. To do 
this select Add Inv button on the Conversation Bar.

130. Next window in the left side faces to move. Then select OK.
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131. After selecting both sides it should look like the model below. 132. The DynaHandle needs to be at the center of the model for the 
sides to rotate about the center. Mouse over the center ball of the 
handle. Hold the left mouse button and drag it to the outside of the 
large cylinder and it will snap to the center.

133. The handle is now at the center but it’s still on an angle. You can 
easily align the handle. Mouse over the Blue handle then use the RMB 
and select Align>Align to Vector.

134. Select the bottom of the edge shown below and the Blue arrow 
will align to that edge.
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132. The DynaHandle needs to be at the center of the model for the 
sides to rotate about the center. Mouse over the center ball of the 
handle. Hold the left mouse button and drag it to the outside of the 
large cylinder and it will snap to the center.

134. Select the bottom of the edge shown below and the Blue arrow 
will align to that edge.

135. Now from the top view (easier to see the change happening) drag 
the Blue arrow and the side ‘wings’ will rotate. If you rotate too far the   
rotation will stop automatically.

136. Select the Blue arrow and enter a value of -5 degrees.

Congrats! The model is done.
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Please watch for future updates on our website as we continue to add 
more functions and subjects for you to try.

More KeyCreator Training:

Kubotek University

Training

www.kubotek3d.com

https://store.kubotek3d.com/university.aspx
https://www.kubotek3d.com/education/training
http://www.kubotek3d.com
https://twitter.com/Kubotek3d
https://www.kubotek3d.com/blog
http://www.youtube.com/user/KuboTuber1
http://www.facebook.com/KeyCreator

